Зарезервированные IP-адреса и немаршрутизируемые диапазоны (bogon)

Некоторые IP-адреса и диапазоны IP-адресов зарезервированы для специального использования, например для локальных или частных сетей, и не должны маршрутизироваться в глобальной сети. Эти зарезервированные диапазоны, а также другие блоки адресов, которые ещё не выделены и поэтому также не подлежат публичной маршрутизации, иногда называют служебными диапазонами (или диапазонами специального назначения).
Зарезервированные IP-адреса и немаршрутизируемые диапазоны (bogon)

Служебные диапазоны IPv4

Сетевой блок Описание
0.0.0.0/8 Данная сеть (адреса источников в текущей сети)
10.0.0.0/8 Частные сети
100.64.0.0/10 NAT операторского класса (CGN)
127.0.0.0/8 Loopback (петлевой адрес)
127.0.53.53 Индикатор коллизии имён (специальный адрес для оповещения о возможной коллизии имён)
169.254.0.0/16 Link-local
172.16.0.0/12 Частные сети
192.0.0.0/24 Назначения протоколов IETF
192.0.2.0/24 TEST-NET-1
192.168.0.0/16 Частные сети
198.18.0.0/15 Тестирование производительности устройств межсетевого взаимодействия (эталонное тестирование по RFC 2544)
198.51.100.0/24 TEST-NET-2
203.0.113.0/24 TEST-NET-3
224.0.0.0/4 Многоадресная рассылка (multicast)
240.0.0.0/4 Зарезервировано для будущего использования
255.255.255.255/32 Ограниченная широковещательная рассылка

Служебные диапазоны IPv6

Сетевой блок Описание
::/128 Неопределённый адрес (используется как адрес источника, пока узлу не назначен постоянный адрес)
::1/128 Петлевой адрес одноадресной рассылки в области узла
::ffff:0:0/96 IPv4-отображённые IPv6-адреса (используются в API сокетов для представления IPv4-адресов)
::/96 Устаревший префикс IPv4-совместимых IPv6-адресов (не используется; признан устаревшим в RFC 4291)
100::/64 Адреса для отбрасывания трафика (блок «только для отбрасывания», RFC 6666)
2001:10::/28 Оверлейные маршрутизируемые идентификаторы на основе криптографического хеша (ORCHID)
2001:db8::/32 Префикс для документации и примеров (RFC 3849)
3fff::/20 Дополнительный префикс для документации (RFC 9637)
fc00::/7 Уникальные локальные адреса (ULA)
fe80::/10 Одноадресная рассылка link-local
fec0::/10 Одноадресная рассылка site-local (устарело)
ff00::/8 Многоадресная рассылка (примечание: ff0e::/16 имеет глобальную область действия и может появляться в глобальном интернете).

Дополнительные служебные диапазоны IPv6

Эти диапазоны не являются официальными служебными диапазонами IPv6 - это IPv6-представления различных служебных диапазонов IPv4.

Сетевой блок Описание
2002::/24 Служебный диапазон 6to4 (0.0.0.0/8)
2002:a00::/24 Служебный диапазон 6to4 (10.0.0.0/8)
2002:7f00::/24 Служебный диапазон 6to4 (127.0.0.0/8)
2002:a9fe::/32 Служебный диапазон 6to4 (169.254.0.0/16)
2002:ac10::/28 Служебный диапазон 6to4 (172.16.0.0/12)
2002:c000::/40 Служебный диапазон 6to4 (192.0.0.0/24)
2002:c000:200::/40 Служебный диапазон 6to4 (192.0.2.0/24)
2002:c0a8::/32 Служебный диапазон 6to4 (192.168.0.0/16)
2002:c612::/31 Служебный диапазон 6to4 (198.18.0.0/15)
2002:c633:6400::/40 Служебный диапазон 6to4 (198.51.100.0/24)
2002:cb00:7100::/40 Служебный диапазон 6to4 (203.0.113.0/24)
2002:e000::/20 Служебный диапазон 6to4 (224.0.0.0/4)
2002:f000::/20 Служебный диапазон 6to4 (240.0.0.0/4)
2002:ffff:ffff::/48 Служебный диапазон 6to4 (255.255.255.255/32)
2001::/40 Служебный диапазон Teredo (0.0.0.0/8)
2001:0:a00::/40 Служебный диапазон Teredo (10.0.0.0/8)
2001:0:7f00::/40 Служебный диапазон Teredo (127.0.0.0/8)
2001:0:a9fe::/48 Служебный диапазон Teredo (169.254.0.0/16)
2001:0:ac10::/44 Служебный диапазон Teredo (172.16.0.0/12)
2001:0:c000::/56 Служебный диапазон Teredo (192.0.0.0/24)
2001:0:c000:200::/56 Служебный диапазон Teredo (192.0.2.0/24)
2001:0:c0a8::/48 Служебный диапазон Teredo (192.168.0.0/16)
2001:0:c612::/47 Служебный диапазон Teredo (198.18.0.0/15)
2001:0:c633:6400::/56 Служебный диапазон Teredo (198.51.100.0/24)
2001:0:cb00:7100::/56 Служебный диапазон Teredo (203.0.113.0/24)
2001:0:e000::/36 Служебный диапазон Teredo (224.0.0.0/4)
2001:0:f000::/36 Служебный диапазон Teredo (240.0.0.0/4)
2001:0:ffff:ffff::/64 Служебный диапазон Teredo (255.255.255.255/32)

6to4 (описан в RFC 3056) - это механизм, который позволял передавать IPv6-трафик через существующие IPv4-сети путём автоматического туннелирования. Идея была в том, чтобы ускорить переход на IPv6, но на практике всё оказалось не так гладко.

Комментарии: 0